Overlapping Cells

Jul 14, 2009 at 12:01 PM

I am going to turn on OverLapping cells,. I have a requirement where, on my calendar, I show days however one event may end at 10am and an other will start at say. 2 pm, since I only show "days" the current implementation will throw an exception, if I turn off the checks of overlapping cells, it appears to render just fine .

What do you guys think, is it something worthwhile to be checked in, or should I just have a one-off for me to use?

 

Derek

Coordinator
Jul 15, 2009 at 7:42 AM

So what your grid will show?   The event that ends at 10am,. or event that starts at 2 pm ?      

 

My personal opinion is that your domain model does not map the same way to how your create your calendar. That is, in your domain model you could have overlapping events, but when it comes to calendar, these special overalapping events must be represented with some special cell type, which can even draw both events in the same cell.

So i think it is the matter how you structure application and your model and your views (in relation to MVC)

Jul 15, 2009 at 11:12 AM
I like the current behaviour. When I have two overlapping cells, they both are spanning more then one cell. So depending on which cell you click on (or has focus) it is on top.
 
If I click on the left cell, it becomes on top, If I click on the right cell, it becomes on top (in the overlapping cell)
 
I never have an issue with having two events in the same cell (with colspan of 1).
 
~D

On Wed, Jul 15, 2009 at 3:42 AM, dariusdamalakas <notifications@codeplex.com> wrote:

From: dariusdamalakas

So what your grid will show?   The event that ends at 10am,. or event that starts at 2 pm ?      

 

My personal opinion is that your domain model does not map the same way to how your create your calendar. That is, in your domain model you could have overlapping events, but when it comes to calendar, these special overalapping events must be represented with some special cell type, which can even draw both events in the same cell.

So i think it is the matter how you structure application and your model and your views (in relation to MVC)

Read the full discussion online.

To add a post to this discussion, reply to this email (sourcegrid@discussions.codeplex.com)

To start a new discussion for this project, email sourcegrid@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com


Coordinator
Jul 15, 2009 at 5:29 PM

Ok, i understand now.

It might be a also a solution to make an option to turn on or turn off this checking.

The default should be to check for overllaping. Only if user prefers, he could disable it on request

Jul 15, 2009 at 5:34 PM
Got it, I'll try to find time to write a patch tomorrow. thanks
Derek

On Wed, Jul 15, 2009 at 1:29 PM, dariusdamalakas <notifications@codeplex.com> wrote:

From: dariusdamalakas

Ok, i understand now.

It might be a also a solution to make an option to turn on or turn off this checking.

The default should be to check for overllaping. Only if user prefers, he could disable it on request

Read the full discussion online.

To add a post to this discussion, reply to this email (sourcegrid@discussions.codeplex.com)

To start a new discussion for this project, email sourcegrid@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com


Jul 15, 2009 at 6:46 PM

I have uploaded a small patch, please consider encorporating it into the baseline, I believe it was coded with respect to your standards, including your recommendation of setting the default to be FALSE.

Coordinator
Jul 22, 2009 at 5:58 AM

Thanks!

I have applied the patch. Hope it solves yours problems :)