This project is read-only.

No Border colors

May 1, 2010 at 4:39 PM

Hi,

I have created a table, but am having issues with single lines of color showing through between cells.

I have set each cell to not use a border..

			DevAge.Drawing.RectangleBorder NoBorder = new DevAge.Drawing.RectangleBorder(DevAge.Drawing.BorderLine.NoBorder, DevAge.Drawing.BorderLine.NoBorder, DevAge.Drawing.BorderLine.NoBorder, DevAge.Drawing.BorderLine.NoBorder);

			SourceGrid.Cells.Views.Cell CourseView = new SourceGrid.Cells.Views.Cell();
			CourseView.Font = new Font("Comic Sans MS", 10, FontStyle.Bold);
			CourseView.Background = new DevAge.Drawing.VisualElements.BackgroundLinearGradient(Color.Gold, Color.White, 0);
			CourseView.Border = NoBorder;

			SourceGrid.Cells.Views.Cell R1View = new SourceGrid.Cells.Views.Cell();
			R1View.Background = new DevAge.Drawing.VisualElements.BackgroundLinearGradient(Color.LightBlue, Color.White, 90);
			R1View.Border = NoBorder;

			SourceGrid.Cells.Views.Cell R2View = new SourceGrid.Cells.Views.Cell();
			R2View.Background = new DevAge.Drawing.VisualElements.BackgroundLinearGradient(Color.White, Color.LightBlue, 90);
			R2View.Border = NoBorder;

			SourceGrid.Cells.Views.Cell CBView = new SourceGrid.Cells.Views.CheckBox();
			CBView.BackColor = Color.Gold;
			CBView.Border = NoBorder;

But I'm getting a white line between certain cells

http://www.betgear.biz/border.png

Is there anyway to tidy this up, or am I missing something?

Cheers

Glen.

 

 

 

May 3, 2010 at 12:50 PM

Further to the above post, it only appears to be happening on cells that have rowspan and column span set.

Glen.

 

May 5, 2010 at 3:06 PM

Hi Glen,

sorry for not responding fast.

Could you please modify one  of the samples to show the problem?

May 5, 2010 at 3:45 PM

Hi,

No problem.

I have created a vs 2008 project that shows the bug. I've cut and pasted bits from my code in order to reproduce it.

The sourcegrid dll is the latest one taken from the repository.

http://www.betgear.biz/gridbug.rar

Cheers

Glen.

May 6, 2010 at 8:57 AM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.